think tank forum

technology » Rants on technology

lucas's avatar
3 years ago
link
lucas
i ❤ demo
I feel like I'm constantly fighting battles against crappy technology:

1. My Samsung Galaxy S4 is unusable when I receive text messages. It demonstrates a UI lag of 5-10 seconds. See video.

2. I live on campus, but my Internet connection in my apartment is unusable. They queue at 8/1 Mbps, and I don't think that they prioritize DNS or ACK packets. When I fill up that 1 Mbps upstream bandwidth with a Youtube upload, I get DNS timeouts every time I try to load a website. Anytime I watch Netflix, with nothing else using the connection, I have to refresh constantly. See video.

3. TTF was offline because I tried upgrading Ubuntu on my Rackspace VPS, and the upgrade failed half-way through. As a result, it had a variety of quirks which made data migration troublesome. I had been wanting to migrate to AWS EC2 anyway, so I tried setting up a new EC2 instance to serve as my production web server. Well, I struggled to get multiple IPs working on the same VPS. The AWS EC2 console was a problem, hidden AWS EC2 IP/if limits were a problem, Linux IP routing with multiple IPs was a problem. Finally I got it all resolved with a nice install of Debian Wheezy. One network interface, a second IP on an if alias. I needed two IPs to run two SSL/HTTPS websites.

And some are my fault:

3. I had two SSDs in my Lenovo Thinkpad x220, an Intel 311 20GB SLC mSATA SSD and a Sandisk Extreme 240GB MLC SATA SSD. I was planning on replacing the Intel SSD with a Crucial M550 256GB MLC mSATA SSD. I bought the Crucial SSD, but it sat around because I was too busy/lazy/ill to install it and migrate everything. As that Crucial SSD sat around, the Intel SSD failed. Sadly, it had my Windows install and my user profiles, and I didn't have a back-up of my EFS keys. So I also lost all the data stored on the Sandisk SSD! I tried every tool I could find to recover the keys from the Intel SSD, but none could read the sectors. So I installed the Crucial SSD, added a Samsung 850 Pro 256GB SATA SSD, and started over from scratch.

The most reliable technology I have is probably my file server (atlas) running FreeBSD on RAID-1 with two enterprise HDDs. I bought an NEC PA272W which is very nice. I thought about using atlas as a desktop with the monitor, but the motherboard doesn't support such a high resolution. Sigh.
andre's avatar
3 years ago
link
andre
1. Have you considered CyanogenMod? I was about to replace my S3, but CM gave it some new life. Still far from perfect, but much better than Samsung's slow crap.

3. Do you guys have any experience with Digital Ocean vs. Amazon EC2?
lucas's avatar
3 years ago
r2, link
lucas
i ❤ demo
I don't know how to root my phone. (Samsung SCH-I545, Android 4.4.2, VRUFNK1)

I've never used Digital Ocean.
DaGr8Gatzby's avatar
3 years ago
link
DaGr8Gatzby
Drunk by Myself
I did Android for a while. I thought I was the bee's knees rooting/imaging/romming. Then I woke up one day and picked up my old iPhone and it was vastly superior. I then bought 2 iPhones. CyanogenMod is the best of a bad situation.

Never used any cloud infra. I have no need for it. I have FIOS now so I run everything locally.
lucas's avatar
3 years ago
link
lucas
i ❤ demo
hey guys, my freebsd box is struggling to write to disk. i'm seriously sitting here waiting for vim to write a new rc.conf. it's happening on both my SSD (/) and my two HDDs in RAID-1 (/home). i don't understand it at all. D:
andre's avatar
3 years ago
link
andre
Lucas, you could try the installer: http://beta.download.cyanogenmod.org/install

It's an automatic process then (that's how I installed it in my phone). OS updates are not very frequent though.
lucas's avatar
3 years ago
link
lucas
i ❤ demo
i'm not on a build that has been broken, i think. ref
lucas's avatar
3 years ago
link
lucas
i ❤ demo
chrome auto-complete: the worst thing ever
lucas's avatar
3 years ago
link
lucas
i ❤ demo
finally freebsd is telling me that one of the disks on atlas is dead:

$ sudo smartctl -a /dev/ada2
smartctl 6.3 2014-07-26 r3976 [FreeBSD 10.0-RELEASE-p1 amd64] (local build)
Copyright (C) 2002-14, Bruce Allen, Christian Franke, www.smartmontools.org 

=== START OF INFORMATION SECTION ===
Model Family:     Hitachi Ultrastar 7K3000
Device Model:     Hitachi HUA723030ALA640
Serial Number:    MK0331YHGB86PA
LU WWN Device Id: 5 000cca 225c51eec
Firmware Version: MKAOA580
User Capacity:    3,000,592,982,016 bytes [3.00 TB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    7200 rpm
Form Factor:      3.5 inches
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 2.6, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is:    Mon Apr 20 17:32:41 2015 PDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: FAILED!
Drive failure expected in less than 24 hours. SAVE ALL DATA.
See vendor-specific Attribute list for failed Attributes.

General SMART Values:
Offline data collection status:  (0x82) Offline data collection activity
                                        was completed without error.
                                        Auto Offline Data Collection: Enabled.
Self-test execution status:      (  38) The self-test routine was interrupted
                                        by the host with a hard or soft reset.
Total time to complete Offline
data collection:                (28081) seconds.
Offline data collection
capabilities:                    (0x5b) SMART execute Offline immediate.
                                        Auto Offline data collection on/off support.
                                        Suspend Offline collection upon new
                                        command.
                                        Offline surface scan supported.
                                        Self-test supported.
                                        No Conveyance Self-test supported.
                                        Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                                        power-saving mode.
                                        Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                        General Purpose Logging supported.
Short self-test routine
recommended polling time:        (   1) minutes.
Extended self-test routine
recommended polling time:        ( 468) minutes.
SCT capabilities:              (0x003d) SCT Status supported.
                                        SCT Error Recovery Control supported.
                                        SCT Feature Control supported.
                                        SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   100   100   016    Pre-fail  Always       -       0
  2 Throughput_Performance  0x0005   136   136   054    Pre-fail  Offline      -       82
  3 Spin_Up_Time            0x0007   139   139   024    Pre-fail  Always       -       497 (Average 617)
  4 Start_Stop_Count        0x0012   100   100   000    Old_age   Always       -       57
  5 Reallocated_Sector_Ct   0x0033   001   001   005    Pre-fail  Always   FAILING_NOW 1983
  7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   133   133   020    Pre-fail  Offline      -       27
  9 Power_On_Hours          0x0012   096   096   000    Old_age   Always       -       29742
 10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       57
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       207
193 Load_Cycle_Count        0x0012   100   100   000    Old_age   Always       -       207
194 Temperature_Celsius     0x0002   153   153   000    Old_age   Always       -       39 (Min/Max 19/47)
196 Reallocated_Event_Count 0x0032   001   001   000    Old_age   Always       -       5721
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       26
198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Extended offline    Interrupted (host reset)      60%     29488         -
# 2  Short offline       Completed without error       00%     29461         -

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

$
Carpetsmoker's avatar
1 year ago
link
Carpetsmoker
Martin
Docker is a piece of shit.